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Introduction 
Welcome to Realtime Landscaping Photo, the ideal software for designing your 
landscape.  

Realtime Landscaping Photo is very easy to use: just import a picture of your house 
and property as a background picture and design the landscape on top. This is a fast 
way to try out different ideas before you commit to a final design. 

Thousands of plants and other items are included. You can adjust these as needed to 
match the size and perspective of your picture. 

System Requirements 
Realtime Landscaping Photo has the following system requirements: 

 1 GHz processor 

 512 MB System RAM 

 Microsoft® Windows® XP Service Pack 2, Vista (all versions) 

 DirectX 9.0c (automatically installed if needed) 

 2 GB available hard drive space 

 DirectX 9-compatible video card with 128 MB graphics memory 

 
Realtime Landscaping Photo uses the latest graphics technology. Using a high quality 
video card will help the program run smoother and improve the quality of the graphics. 
If your video card does not meet the requirements for hardware acceleration, then 
software emulation will be used automatically. 

Please check with your video card manufacturer and make sure you are using the 
latest video drivers. 

Installing the Software 
To install the software, insert the CD and follow the installation instructions. If the 
installation program does not automatically start: 

1. Click the Windows Start button and select Run. 

2. Type d:\setup.exe, replacing d: with the drive letter of your CD-ROM if 
needed. Then click OK. 

3. Follow the installation instructions. 

Installing DirectX 
DirectX 9.0c is required to run Realtime Landscaping Photo. The installation program 
will ask you if you want to install it. Be sure to click Yes to allow the installation to 
continue. The DirectX installer will detect if a newer version is already present on your 
computer and only proceed if needed. 
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Program Help 
Realtime Landscaping Photo comes with comprehensive help built into the program. 
To learn more about the currently selected object or dialog box, press F1. To learn 
more about other options, select Help > Contents. 

Running the Program 
Once the program has been installed, double-click the Realtime Landscaping Photo 
icon on your desktop. The Welcome Menu will then appear: 
 

 

Open a Saved Landscape 
Click this option to open a landscape you have previously created and saved. 

Open a Sample Landscape 
Click this option to open a sample landscape. The examples are a great way to see 
what the program is capable of. 

Import a new Background Picture using the Wizard 
Click this option to open the Picture Import Wizard and import a new background 
picture. 

View Online Tutorials at IdeaSpectrum.com 
Click this option to view online tutorials for Realtime Landscaping Photo. This is a 
great way to continue learning how to use the software.  
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Show these options at startup 
If you do not want the Welcome Menu to appear each time you run Realtime 
Landscaping Photo, uncheck this option. 

Exit Button (top right) 
Click this button to exit the welcome menu and start a new landscape design from 
scratch. 

User Interface 
The user interface has the following elements: 

 

Menu Bar 
This is the standard Windows menu bar. For a quick description of a particular menu 
command, point to the command and read the description from the dynamic help 
window. For more information about using menus, please consult your Windows 
documentation. 
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Object Creation Tools 
To create an object, first click the toolbar button representing the desired object. Then 
follow the instructions in the dynamic help window.  

To determine the function of a particular button, position your mouse over the button 
and wait a few seconds for the corresponding tooltip to display. For detailed 
information, click the button and then press F1. 

Object Properties 
These controls allow you to modify the appearance and other options of your objects. 

Editing Tools 
The Editing tools allow you to select, rotate, and resize your objects. When you select 
an object, you can also edit its properties. 

View Tools 
The View tools allow you to pan and zoom the view. You can also use your mouse to 
adjust the view. 

Layer Tabs 
The Layer tabs help you organize your landscape design into layers. For example, you 
could place all of your fill regions into a layer and lock them to prevent them from 
being selected while you work on other areas of your design. 

Rotate & Resize 
Click and drag these handles to quickly rotate or resize your objects. 

Dynamic Help 
This area displays dynamic help for the currently selected object or tool. When 
creating an object, for example, the dynamic help will give you a description of each 
step. 

Importing a Background Picture 
The first step to designing your landscape is to take a picture of your house and 
property using a digital camera. For best results, take the picture on a clear day with 
the sun behind you (to avoid glare). Try to get as close as possible to the area you 
want to landscape. If the area is too big to fit in a single picture, then you can take 
several pictures and create a separate landscape design for each.  

Next, upload the picture to your computer using the software that came with your 
camera. (Scanned pictures will work as well.)  

Then import your picture using the Picture Import Wizard with the following steps. 
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To import a background picture: 

1. Start Realtime Landscaping Photo. 

2. From the welcome menu, click Import a new background picture using the 
wizard. Or, if the welcome menu is not active, select Tools > Picture Import 
Wizard. 

3. Click Next.  

4. Select Background and click Next.  

5. Navigate to your picture and click Open.  

Note: When you upload pictures from your digital camera, they are usually 
placed in the folder named My Pictures.  

6. Your picture will then be displayed. To select a different one, click the picture 
and repeat the previous step. If this is the picture you want to use, click Next. 

7. Click Set File Name and enter a name for the imported picture. Pictures from 
digital cameras usually have cryptic names, such as DSCN1668.JPG. This 
step lets you give the imported picture a name that is easier to remember. 

8. Click Next and then Finish. Your picture will appear in the background and 
you can begin designing the landscape.  

Important: The wizard will make a copy of your picture. If you change the original, 
then you will need to re-import it using the wizard. 

Use the Picture Import Wizard to import your background picture 
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Changing the Background Picture 
Once you have imported a picture, you can choose it without having to import it again. 
Click Tools > Background Picture Settings and click the picture to select a new 
one. 

You can edit the imported background picture using the Realtime Picture Editor. See 
the program help for details. 

Designing your Landscape 
Once you have imported your background picture, you are ready to begin designing 
the landscape. Realtime Landscaping Photo includes a large variety of plants and 
other objects to help you create your designs. The software includes powerful tools for 
adjusting the shape and size of the objects to help them fit seamlessly with your 
picture.  

Adjusting the View 
Using the Pan and Zoom tools, you can adjust the view to more easily work on any 
portion of your landscape design. 

Panning the View  

To pan the view: 

1. Click Pan.  

2. Position the cursor inside the view, then click and drag. When finished, 
release the left mouse button. 

Mouse Shortcut: You can pan by clicking and dragging with the middle mouse button. 
This is quicker than clicking Pan every time you want to pan the view. 

Keyboard Shortcut: The keyboard arrow keys can also be used to pan the view. 

Zooming the View  

To zoom the view: 

1. Click Zoom.  

2. Position the cursor inside the view, then click and drag up or down to adjust 
the zoom. When finished, release the left mouse button. 

Mouse Shortcut: You can zoom by rotating the mouse wheel. Or, you can hold down 
the left & right mouse buttons while you drag up and down. Either way is quicker than 
clicking Zoom every time you want to zoom the view. 
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Zooming into the Selection  

To zoom into the current selection: 

1. Click Zoom to Selection or press Z.  

The view will zoom into the selected objects. If no objects are selected, then the view 
will zoom to the entire landscape design. 

Zooming into a Rectangle  

To zoom into a rectangle: 

1. Click Zoom to Rectangle. 

2. Click and drag to draw a rectangle. When you release the mouse button, the 
view will be zoomed so that the rectangular area fills the view. 

Adding Objects 
Realtime Landscaping Photo includes nine powerful objects that you can use to build 
your landscape. Each object has a specific set of options for controlling its appearance 
and behavior. For example, the Light object has options for setting the color and 
intensity of the light. 

To add a new object: 

1. Click the toolbar button for the object you want to add. 

2. Change the object�s default properties, if desired. 

3. Follow the instructions in the Dynamic Help window to add the object to your 
landscape design.  

Once an object has been added, it is automatically selected for editing. See Editing 
Objects on page 20 for instructions on how to select and edit objects. 

Tip: Press F1 while adding the object for detailed instructions.  

Adding a Plant  

Realtime Landscaping Photo includes a large variety of plants commonly used in 
landscapes around the world. These are high-resolution photographs of real plants, 
not drawings or models. The background has been professionally removed so they 
can be seamlessly placed in your landscape designs. 

All of the plants included with Realtime Landscaping Photo can be edited using the 
Realtime Picture Editor (included), so you can easily make changes and even create 
new varieties. You can also import and edit pictures of plants that you have 
photographed using a digital camera or downloaded from the Internet. 
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To add a plant: 

1. Click Add Plant. 

2. Select the desired plant by clicking the picture in the property window.  

3. Click to add the plant. Hold Ctrl while you click to add more than one. 

4. Move and size the plant as desired. To move the plant, position the cursor 
over the plant and drag using the mouse. To resize, click and drag the green 
rectangle to the upper right of the plant. 

Press F1 for more detailed instructions, including details on how to search for plants, 
edit their color and brightness, create custom plant varieties, and more. 
 

 
Some of the many plants included in Realtime Landscaping Photo 
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Adding a Fill Region  

A region is a closed area filled with a material. It can be used for ground cover, 
driveways, patios, and more. Regions can be any shape or size. Many materials are 
included, such as grass, rock, stone, and brick. 

To add a region: 

1. Click Add Region. 

2. Select the desired material by clicking the picture in the property window. 

3. Draw the region�s outline by clicking to add points. Press Backspace to 
remove the last point. Press Esc to cancel. 

4. Click the starting point to close the outline. Or, right-click to automatically join 
the last point to the first. 

Once you have added a region, you can easily change its shape. See Editing Points 
on page 24 for details. 

A fill region was used for the new lawn in this design 
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Adding a Picture  

In Realtime Landscaping Photo, the Picture object is used to add pictures of planters, 
rockery, statuary, and other objects. Many different types of pictures are included, and 
you can import your own.  

To add a picture: 

1. Click Add Picture. 

2. Select the desired picture by clicking the picture in the property window. 

3. Click to add the picture. Hold Ctrl while you click to add more than one. 

4. Move and size the picture as desired. 

 

 
The Picture object was used for the bench in this design 
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Adding an Accessory  

A large variety of accessories are included for use in your landscape designs, 
including arbors, greenhouses, planters, outdoor kitchens, and more.  

Accessories are 3D models, not pictures. While pictures of real objects are very 
realistic, they don�t always match the viewpoint or perspective of your background 

picture. With the extensive library of 3D models in Realtime Landscaping Photo, you 
can rotate, scale, and change their perspective as needed to seamlessly blend into 
your landscape design. 

To add an accessory: 

1. Click Add Accessory. 

2. Select the desired accessory by clicking the picture in the property window. 

3. Click anywhere in the view to add the accessory.  

4. Using the property controls, adjust the accessory�s size, rotation angles, and 

perspective to match your design. 

 

The brick columns, fencing, and bridge in this design were  
added using the Accessory object 
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Adding Edging  

Edging adds a nice border around your flower beds, paths, and other areas of your 
landscape. You can easily adjust the size and shape of your edging. Realtime 
Landscaping Photo includes many types of edging materials, including rock, stone, 
brick, and marble. 

To add edging: 

1. Click Add Edging. 

2. Draw the edging�s outline by clicking to add points. Press Backspace to 
remove the last point. Press Esc to cancel. 

3. Click the starting point to close the edging. Or, for edging that remains open 
instead of closed, right-click at the last point. 

Once you have added edging, you can easily change its shape. See Editing Points on 
page 24 for details. 
 

The edging around the flower bed was added using the Edging object 
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Adding a Retaining Wall  

Retaining walls are often used on steeply sloped lots and terraces to provide support 
and prevent erosion. They can also be used as decorative partitions between areas of 
your landscape. 

To add a retaining wall: 

1. Click Add Retaining Wall. 

2. Draw the retaining wall�s outline by clicking to add points. Press Backspace 
to remove the last point. Press Esc to cancel. 

3. Right-click at the last point when finished. 

Once you have added a retaining wall, you can easily change its shape. See Editing 
Points on page 24 for details. 
 

This retaining wall�s middle point has been  
elevated, creating a curved wall 
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Adding a Landscape Light  

Realtime Landscaping Photo includes a wide variety of landscape lights such as 
traditional garden lights, spotlights, and Japanese lanterns. The lights will 
automatically turn on when viewing your landscape at night. 

To add a landscape light: 

1. Click Add Light. 

2. Select the desired light by clicking the picture in the property window. 

3. Click to add the light. Hold Ctrl while you click to add more than one. 

4. Using the property controls, adjust the light�s size, rotation angles, and 

perspective to match your landscape design. 

Nighttime Viewing  

You can toggle between day and night viewing of your design by clicking the Night 
button.  

To configure how your landscape appears during the day or night, click Settings > 
Environment Settings. 

Example of day and night viewing 
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Adding a Mask  

A mask is an area that prevents objects in front of it from obscuring what�s behind it. 

For example, suppose you have a fence in your background picture and want to add 
trees behind it. By adding a mask over the fence you can prevent the trees from 
drawing on top of the fence. 

To add a mask: 

1. Click Add Mask. 

2. Draw the mask�s outline by clicking to add points. Press Backspace to 
remove the last point. Press Esc to cancel. 

3. Click the starting point to close the outline. Or, right-click to automatically join 
the last point to the first. 

Once you have added a mask, you can easily change its shape. See Editing Points on 
page 24 for details. 

In the following example, notice the trees that have been added behind the fence. A 
mask was used to prevent them from drawing in front of the fence, which is part of the 
original picture. 

This design uses the Mask object to prevent the  
background trees from drawing over the fence 
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Adding Text  

You can add text to your landscape design. This is useful for labeling plants, 
identifying the designer, and other information.  

To add text: 

1. Select Add Text. 

2. Click where you want to add the text. 

3. Click the text box in the property window and enter the desired text. 

4. Move, size, and rotate the text as needed. 

 

This landscape design uses text to identify the client and designer 
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Editing Objects 
Realtime Landscaping Photo includes several easy-to-use tools for selecting and 
editing your objects.  

Selecting Objects  

To move, rotate, or scale an object, or to change its properties, you must first select it. 
There are several ways objects can be selected, depending on what you want to do. 

To select objects one at a time: 

1. Position the cursor over the object. 

2. Click to select the object. All other objects will be automatically deselected. 
If you click over multiple overlapping objects, the closest object will be 
selected first. If you continue clicking, then the next closest object will be 
selected, and so forth. 

3. If you want to select an additional object, press and hold Shift while clicking 
the object. 

To select objects using a selection rectangle: 

1. Pan and/or zoom until the objects you want to select are fully inside the 
view.  

2. If you want to add to your current selection, press and hold Shift. 

3. Click and drag to draw the selection rectangle. The rectangle must fully 
surround the objects you want to select. When you release the left mouse 
button, the objects will be selected. 

When an object is selected, it renders a special shape to indicate the selection. 
Objects defined by an outline (such as a fill region or edging), render the outline that 
defines their shape. Other objects, such accessories and landscape lights, render a 
rectangle around the entire object. 

Tips:  

 Click Undo to undo accidental selections. 

 You can lock objects to prevent them from being selected, either by type 
(using View > Show/Hide Objects) or by layer (using View > Edit Layers). 
See the program help for details. 
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Moving, Rotating, and Scaling Objects  

To move, rotate, or scale an object that is not currently selected: 

1. Click the desired tool, or press T to move, R to rotate, or S to scale. 

2. Position the cursor over the object and click to select it. 

3. Drag the mouse to move, rotate, or scale the object. 

To move, rotate, or scale multiple objects: 

1. Select the objects you want to modify. 

2. Position the cursor over any of the selected objects. 

3. Click and drag to move, rotate, or scale the objects. 

 
Tip: When using the Move tool, you can also quickly rotate and scale your objects by 
dragging the green rotation dot and scaling rectangle, as shown below.  

 
Handles make it easy to rotate and scale your objects 

Deleting Objects 
To delete one or more objects: 

1. Select the object(s) you want to delete. 

2. Press Del, or right-click and select Delete from the popup menu. 
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Cut, Copy, & Paste 
The copy and paste features of Realtime Landscaping Photo make it easy to create 
copies of your objects. 

To copy objects to the clipboard and delete them from the landscape: 

1. Select the object(s) you want to cut. 

2. Press Ctrl+X, or right-click and select Cut from the popup menu. 

To copy objects to the clipboard: 

1. Select the objects you want to copy. 

2. Press Ctrl+C, or right-click and select Copy from the popup menu. 

To paste objects from the clipboard: 

1. Press Ctrl+V, or right-click and select Paste from the popup menu. The 
objects will be slightly offset from the originals and automatically selected. 
The Move tool will also be automatically selected. 

2. Move the pasted objects to the desired position. 

Grouping & Ungrouping Objects 
When working with a large number of objects, it is often useful to group them into a 
single object to make them easier to select and move. For example, once you�re 

happy with a set of plants, you might want to combine them into a group and focus on 
other areas of your landscape.  

To group a set of objects: 

1. Select the objects you want to group. 

2. Right-click and select Group from the popup menu. 

To ungroup one or more groups: 

1. Select the groups you want to ungroup. 

2. Right-click and select Ungroup from the popup menu. 

Controlling the Render Order 
When working with overlapping plants, fill regions, and other objects, you can control 
which ones are rendered first. For example, you can use this to ensure plants appear 
on top of the lawn. 
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To change an object�s render order: 

1. Select the object you want to change. 

2. If you want the object to render on top of all other objects, right-click and 
select Bring to Front or press Ctrl+F. Or, if you want the object to render 
beneath all other objects, right-click and select Send to Back or press 
Ctrl+B. 

If you want to bring the object one more step towards the top of a group of 
overlapping objects, right-click and select Bring Forward or press F. Or, if 
you want to send the object one more step towards the bottom of a group of 
objects, right-click and select Send Backward or press B. 

You can change multiple objects with this command. That is, selecting multiple objects 
and using Bring to Front will cause the selected objects to render in front of the 
unselected objects.  

Setting Object Properties 
Objects are defined by their properties. A property is an option that determines how 
the object will look or function. The Property Window, shown below, displays the 
properties associated with the currently selected object(s). 

 

Feel free to experiment � any changes you make can be easily reversed by clicking 
Undo. 

Default Properties 
Whenever you add an object, the object�s default properties will be displayed. You can 
change these defaults any time after you click the object�s toolbar button, but before 
you actually finish adding the object. This does not affect objects already in the 
landscape, but only new objects that are added from then on.  
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Editing Properties for Multiple Objects 
A powerful feature of Realtime Landscaping Photo is its ability to edit multiple objects 
of the same type. For example, suppose you want to change multiple plants to the 
same flower. Instead of having to select and change each one individually, you can 
select all of them and make the change just once. 

When you select multiple objects of the same type, any of the properties that are 
different will appear blank. See the program help for details. 

Undoing & Redoing Changes 
 

 

Realtime Landscaping Photo has a very powerful undo system, giving you the 
freedom to experiment and try new things. The number of undo levels is unlimited, so 
you can backtrack all the way up to the point where you last opened your landscape. If 
you decide you want your changes after all, you can redo your changes as far as 
needed. 

Editing Materials 
You can customize the appearance of plants, accessories, and other objects after you 
have added them to your landscape design: 

To change the materials of an object: 

1. Select the object. 

2. Click the options button to the right of the model, material, or picture. 

A menu will then appear with your choices. Options include changing materials of 3D 
models, editing color and brightness, and editing using the Realtime Picture Editor. 
See the program help for detailed instructions. 

Editing Points  
Objects such as fill regions, pictures, and masks are defined using an outline, called 
their shape. The Edit Points option enables editing of the points that define the 
shape. 

To enable point editing: 

1. Click Edit Points in the object�s property window. The button will turn yellow 

and the object�s points will appear in the view. 

2. Edit the points as desired (see the following topics for details). 

To move points: 

1. Select the point(s) you want to move. 

2. Click and drag any of the selected points to move them all. 

Tip: Sometimes you want to move edges, not individual points. To do this, click and 
drag the edge. The two points that form the edge will be automatically selected and 
moved. 



25 

When you are finished editing points: 

1. Click Edit Points. The button will turn blue, and the object�s points will 

disappear from the view. 

2. You can then select and edit objects normally. 

You can also scale and rotate points. See the program help for details. 

Important: When editing points, the move, rotate, and scale tools will only affect the 
selected points, not the entire object. Also, you will only be able to select points, not 
other objects. To exit point editing mode and return to normal editing mode, click the 
yellow Edit Points button. 

Changing the Curve Type 
You can use straight lines, curved lines, or any combination in your shapes. This helps 
you create fill regions, edging, and other objects at exactly the size and shape you 
want. 

Four types of curves are supported: Straight, Spline, Bezier, and Bezier Corner. 

 

To change the curve type: 

1. Select the points you want to change. 

2. Click the desired curve type button shown above. 

See the program help for a description and example of each curve type. 

Editing Bezier Curves 
When points are selected that use the Bezier or Bezier Corner curve type, two blue 
dots will appear, called handles. You can drag these handles to adjust the shape of 
the curve. Unlike normal points, the Bezier handles cannot be selected; you can only 
drag them using the mouse.  
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Bezier curves give you precise control over your shapes 
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Inserting & Deleting Points 
You can insert and delete points as needed to obtain the desired shape. 

To insert points: 

1. Click Edit Points to enable point editing (if needed). 

2. Press and hold Ctrl. 

3. Position the cursor over the edge where you want to insert a new point and 
left-click. 

4. Repeat for each point you want to insert. 

To delete points: 

1. Select the points you want to delete. 

2. Press Del.  

Tip: If you need more control over the shape you�re editing, you can insert additional 
points. You can also change the curve type as described on page 25. 

Technical Support 
Have a question about a feature, or a suggestion for how we can make the software 
even better? We�d love to hear from you. Please email support@ideaspectrum.com 
or call toll free 1-866-894-4332 (Mon-Fri 9-5 Pacific Standard Time). Outside the U.S. 
call 253-862-2678. 

mailto:support@ideaspectrum.com


CONTROL QUICK REFERENCE 
FILE 
New Ctrl+N
Open Ctrl+O
Save Ctrl+S
 

EDIT 
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del
Undo Ctrl+Z
Redo Ctrl+Shift+Z
Bring to Front Ctrl+F
Send to Back Ctrl+B
Bring Forward F
Send Backward B
 

VIEW 
Pan Mouse middle-click and drag
Zoom Mouse wheel, or mouse left+right click and drag
Zoom to selection Z
 

TOOLS 
Move tool T
Rotate tool R
Scale tool S
 

 


